D&C GLug - Home Page

[ Date Index ] [ Thread Index ] [ <= Previous by date / thread ] [ Next by date / thread => ]

Re: [LUG] DVDs won't automount in Mint 15 inc Link!


On 06/11/13 01:05, bad apple wrote:
On 06/11/13 00:38, Julian Hall wrote:

Yes that makes perfect sense.  I haven't tried data DVDs to be
honest, all the DVDs thus far have been movies.  As you mentioned
libdvdcss it's highlighted that perhaps I haven't been clear enough
describing the problem as I've been fixated on the mount issue.
Once the DVD mounts it plays perfectly well in VLC Media Player.

To answer the second part of the question, tonight for instance I
rebooted Mint three times with the same disk in the drive and only
on this last attempt did the DVD mount.  So the first case is
true, sometimes it mounts and sometimes not - it is not disk
specific. Also it will only mount if a disk is in the drive at
boot, and will not auto-detect if a disk is inserted when the
system is already running.

I may have confused the issue mentioning BluRay, I was simply
referring to the drive model not the disks in use - I don't have
any actual BluRay disks yet.  All disks I have tried so far have
been standard definition DVDs.  IIRC I mentioned the drive type as
I was curious if it might be some kind of compatibility issue.

Interesting. First, grab a couple of known-good data DVDs, preferably
ones you've burnt yourself, and stick them in, and see what happens.

When I say "see what happens", I mean apart from waiting for the icon
to hopefully appear on your desktop and in Nemo, more importantly run
"dmesg" in a terminal and check the last few lines where there should
be obvious DVD-related information. Post them here if you're not sure
how to interpret them.

Repeat this a couple of times with a couple of your film DVDs as well,
checking dmesg every time.
Zero mention of anything related to the DVD drive in dmesg. I've tried with one data disc I burned myself - the Mint 15 disk, not a flicker and nothing in dmesg.. the last entry is about my USB mouse.
Other things that may be going wrong:

1: screwed up udev rules
How would I check those please?
2: libdvdcss2 not actually as installed as you think it may be*
Once the drive mounts DVDs play flawlessly, plus as per below data disks won't mount either.
3: strange group/permission settings (are you in cdrom/plugdev?)
julian@Cerce ~ $ groups
julian adm cdrom sudo dip plugdev lpadmin sambashare

I do seem to be in both.
4: problems relating to region settings on your DVD/bluray unit
Would that not give a permanent problem rather than what appears to be (but probably isn't) random?

It would definitely be worth testing that you can always manually
mount disks of any kind first, to rule out deeper errors. If you have
issues with this, the problems are deeper than automount being broken.

I'm sure you know how, but to be on the safe side:

sudo mkdir /mnt/dvd-test
sudo mount -t iso9660 /dev/sr0 /mnt/dvd-test

Your unit might not actually be /dev/sr0, but probably is. It's almost
undoubtedly linked to /dev/cdrom.
julian@Cerce ~ $ sudo mkdir /mnt/dvd-test
[sudo] password for julian:
julian@Cerce ~ $ sudo mount -t iso9660 /dev/sr0 /mnt/dvd-test
mount: special device /dev/sr0 does not exist
julian@Cerce ~ $

When I replied last night - and in fact every other time it /has/ mounted, I've looked in /dev and sr0 has been there, but not when it doesn't, so you're right it should be /dev/sr0.

Kind regards,


The Mailing List for the Devon & Cornwall LUG
FAQ: http://www.dcglug.org.uk/listfaq