D&C GLug - Home Page

[ Date Index ] [ Thread Index ] [ <= Previous by date / thread ] [ Next by date / thread => ]

[LUG] Synology NFS Shared Folder Inaccessible But Does Mount.


Hi All,

A bit of an oddball one - well it's me you're probably used to that by now. After replacing the failed HDD in my Synology DS212j I decided to split my files among Graphics, Video and General. That has worked up to a point. The configuration is:

Cerce - Main PC - Fixed IP
Zeus - NAS - Fixed IP with three Shared Folders:

HERA: General Files
DIANA: Graphics Files

First of all I was able to access them by browsing the network, and entering the UID and PWD to access them. That's how I transferred all the files to them. However long term that's a pain in the bum so I want them to auto mount on boot. Initially none of them would mount at all using

sudo mount -t nfs /media/julian/HERA

for example, so I had a poke around and found Synology's guide for getting NFS Shared Folders to work. All three now have NFS Permissions to allow Read/Write access. I tried first of all in a terminal before adding them to the fstab - and potentially rendering the system unbootable if it hung trying to load them. This is where it gets odd. Diana and Persephone mount perfectly well with the above sudo command and can be browsed as normal. Hera however mounts with no error but refuses any attempt to browse it. There is no error message, simply nothing happens.

Then I added Diana and Persephone to the fstab and rebooted. Both function perfectly, however as Hera has my main files on I need that to mount properly too. Any ideas please?

Kind regards,


The Mailing List for the Devon & Cornwall LUG
FAQ: http://www.dcglug.org.uk/listfaq